MidiTzer "PupiTzer" Linux Uploads

Installation of the Miditzer on Linux machines
User avatar
ggoode.sa
Posts: 69
Joined: Sun Oct 14, 2007 10:46 am
How many Style 216 did Wurlitzer make?: 0
Location: South Africa
Contact:

Post by ggoode.sa » Sun Nov 09, 2008 7:07 am

Hi Craig,If that doesn't work then open /etc/modprobe.conf and add 'alias eepro autodetect=1' to the end of the file. Save it and reboot.Let us know if you still need help after trying this, the next step to try would be to add a simple startup script.GrahamGJohannesburg, South Africa

User avatar
Wurlitzer28
Posts: 216
Joined: Tue Jul 15, 2008 11:45 am
How many Style 216 did Wurlitzer make?: 0
Location: United States

Post by Wurlitzer28 » Sun Nov 09, 2008 7:53 am

I did edit the file you suggested Graham with no noticable changes in operation.
 
During boot when Puppy displays a list of "services" or things being loaded followed by "DONE" in green. When it gets to the network line it says (in yellow) "backgrounded"
 
Upon entering ifconfig -a I do see the "lo" "local loopback" but not the "eth0" information that does appear after I manually do the modprobe eepro autodetect=1 and then use the connect Wizard to run the test and then DHCP.
 
Thanks for working with a Linux dunce!
 
Craig

User avatar
ggoode.sa
Posts: 69
Joined: Sun Oct 14, 2007 10:46 am
How many Style 216 did Wurlitzer make?: 0
Location: South Africa
Contact:

Post by ggoode.sa » Sun Nov 09, 2008 8:06 am

Hi Craig,Ok, let's try this: [I'm using Puppy 4.1.1] Open the Text Editor (click on the Edit icon on the desktop). Start a new file by clicking on 'New'. Type in 'modprobe eepro autodetect=1' and then save the file as 'startnetwork' in the /root/Startup directory. Close the Text editor once the save is complete. Now open the file navigator (click on File on the desktop) and navigate to the Startup directory (click on Startup to enter the directory). Right click on the new file (startnetwork) and select 'Permissions' from the menu. Click on 'Yes'. Restart.Does it work? :-)GrahamGggoode.sa2008-11-09 08:07:59

User avatar
Wurlitzer28
Posts: 216
Joined: Tue Jul 15, 2008 11:45 am
How many Style 216 did Wurlitzer make?: 0
Location: United States

Post by Wurlitzer28 » Sun Nov 09, 2008 8:25 am

No joy yet Graham!
 
I had no problem creating and saving the file as you suggested and setting the permissions.
 
Upon reboot, still not connected.
 
It would seem that there must be a 2 step process as when I manually enter the modprobe eepro autodetect=1 and then open the "connect" wizard at that point I do see the 'etho' listed and I have to 'test' then 'dhcp'
 
Is the modprobe command at boot supposed to also perform the dhcp function?
 
Right now, it looks like the new file does not even perform the 1st step in the process as when I open the 'connect' wizard it does no show any active connections and just prompts me to try and find the right module.
 
Thanks Graham,
Craig

User avatar
Wurlitzer28
Posts: 216
Joined: Tue Jul 15, 2008 11:45 am
How many Style 216 did Wurlitzer make?: 0
Location: United States

Post by Wurlitzer28 » Sun Nov 09, 2008 8:58 am

Seems like I have taken 2 steps back.
 
Now I can no longer manually autodetect eepro
 
If I enter 'modprobe eepro autodetect=1', I receive a "FATAL: Module autodetect=1 not found" error message.
 
The FATAL error message seemed to be because in all my attempts I had left the same script 'modpro ........' in another file. Removing all my previous edits allowed me to at least get back to where I was this morning.
 
I then recreated Graham's suggestion and again created a new file
/root/Startup/startnetwork and placed the line:
 
 'modprobe eepro autodetect=-1'
 
I rebooted and now I see via 'ifconfig -a' that there is now a eth0 connection but no ip address.
 
I went back to the file Graham wanted me to create and added:
'dhcpcd -d eth0' and rebooted. SUCCESS!
 
Thanks for the helping hands,
Craig
 Wurlitzer282008-11-09 11:47:14

User avatar
ggoode.sa
Posts: 69
Joined: Sun Oct 14, 2007 10:46 am
How many Style 216 did Wurlitzer make?: 0
Location: South Africa
Contact:

Post by ggoode.sa » Sun Nov 09, 2008 2:24 pm

Hi Craig,Glad you got it working! Now we all know a little bit more too :-)GrahamG

aonesur
Newbie
Posts: 1
Joined: Thu Aug 19, 2021 8:14 am
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12

Re: MidiTzer "PupiTzer" Linux Uploads

Post by aonesur » Thu Aug 19, 2021 12:56 pm

I did as was suggested an clicked on 24 bit video and the program works great. It found the sound card, I did not have to do anything except click on those boxes that were complaining. about things that weren't really wrong anyway. Thanks to all who have worked hard on this project. Is there a way to import midi music files into the program like you can with the Windows version, or is this something for a future version. surveyzop

User avatar
Jim Henry
Admin Group
Posts: 6216
Joined: Mon May 23, 2005 11:44 pm
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: United States

Re: MidiTzer "PupiTzer" Linux Uploads

Post by Jim Henry » Fri Aug 20, 2021 11:02 am

Hopefully one of our Linux based users while chime in with a better reply.

If the built-in MIDI player does not work under Linux, you might be able to add a virtual MIDI cable and connect an external MIDI file player to the Miditzer with the virtual MIDI cable. In the Windows world, LoopBe and LoopMIDI are two choices for a virtual MIDI cable. All the external MIDI players that I know about are definitely Windows only programs.
Jim Henry

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest