Delayed Sound

Job one is installing the Miditzer and getting it configured
User avatar
Joe Roberts
Groupie
Posts: 90
Joined: Sat Nov 19, 2011 11:18 pm
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: Milwaukee WI. USA
Contact:

Re: Delayed Sound

Post by Joe Roberts » Wed Nov 30, 2011 10:54 am

:D Thanks Jim.............I think the delayed sound will be of benefit....especially if one gets to play a real pipe organ (which I have had the priviledge of).....then the delay will make him/her feel right at home....!

markey111
Senior Member
Posts: 327
Joined: Wed Sep 28, 2011 6:08 am
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: halifax west yorkshire uk

Re: Delayed Sound

Post by markey111 » Fri Dec 02, 2011 7:37 am

I know what you are saying I have played wurlitzer pipes (this one when it was installed near Harrogate north yorkshire http://www.facebook.com/pages/The-Salta ... 4754105041 ) and the delay is acceptable ( to anyone interested this organ is once again available for 'practise sessons @ £15 per hour.. club membership required after the first session), but what i found with windows 7 was the delay wasn't constant, the degree of latency changed as you were playing and for some reason was greater on the accomp manual than great and solo yet virtually none on the pedals. had the latency been constant across the whole organ then it would have been less of a problem

User avatar
Joe Roberts
Groupie
Posts: 90
Joined: Sat Nov 19, 2011 11:18 pm
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: Milwaukee WI. USA
Contact:

Re: Delayed Sound

Post by Joe Roberts » Fri Dec 02, 2011 3:39 pm

OK....ok......I give up............The delayed sound is starting to irk me.....especially when I combine voicings of my Technics FA1 and play together with MITZIE.....lol........WOWie...what sounds I can enjoy.....it almost makes me squirt!!!! Anyway, my fingers are all numb and bloody from playing for hours.......My PC battery is low (I transport it from my office to my Technics console and back). I made the adjustments (from the PDF files)...but I won't be able to check it out till tomorro.........I'll let ya'all know what happened soon..... :roll: Joseph Roberts

markey111
Senior Member
Posts: 327
Joined: Wed Sep 28, 2011 6:08 am
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: halifax west yorkshire uk

Re: Delayed Sound

Post by markey111 » Mon Dec 05, 2011 12:18 pm

any luck? lol

User avatar
Per_S
Posts: 311
Joined: Wed Jan 26, 2005 10:15 am
How many Style 216 did Wurlitzer make?: 0
Location: Sweden

Re: Delayed Sound

Post by Per_S » Sat Apr 07, 2012 1:13 am

I finally decided to retire my old (2003) XP organ computer. After looking around I couldn’t find a suitable off the shelf computer. Most of these are geared towards gaming and not really suited for organ applications. The solution was to assemble one from various parts. Here’s the list: Intel I5 2500 3.3 GHz, 8 GB of memory, 2TB hard disk, MSI motherboard, Windows 7 64bit. My console is an old Rodgers, three manuals, pedals, stop keys, swell shoe, all mixed down to one single MIDI cable using Midibox feeding an EMU 0404 PCI Sound card (reused from my old organ computer).
When the system was up and I tried the 216 and the 260 and both behaved flawlessly without changing anything (apart from assigning channels). No (noticeable) latency and no problems with saving configurations.
I was a bit worried that I would run into endless tweaking to get reasonable performance. Sigh of relief and back to playing.
Per S

markey111
Senior Member
Posts: 327
Joined: Wed Sep 28, 2011 6:08 am
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: halifax west yorkshire uk

Re: Delayed Sound

Post by markey111 » Sun Apr 15, 2012 11:00 am

that was lucky lol
I couldn't get a decent sound with windows 7 at all no matter how I tweaked it. even now i have to reset the priority setting on start up to get it perfect

reuel
Senior Member
Posts: 219
Joined: Tue Nov 03, 2009 5:44 am
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: Australia

Re: Delayed Sound

Post by reuel » Tue Apr 17, 2012 4:26 pm

markey111 wrote:that was lucky lol
I couldn't get a decent sound with windows 7 at all no matter how I tweaked it. even now i have to reset the priority setting on start up to get it perfect
As fluidsynth and your sound card drivers are BACKGROUND tasks, increasing the processing priority for background services (and with it, the priority of fluidsynth and the audio driver) often contributes to better over-all audio performance.

To configure your computer to process background services with higher priority, do the following:
• Right click the "Computer" icon on your desktop. Then select "Properties" > "Advanced System Settings".
• On the "Advanced" tab under "Performance" click the "Settings..." button.
• Again, on the "Advanced" tab under "Performance Options" select "Background services".

Rationale:
It is incorrect to give too much priority to Miditzer itself. Windows 7 x64 works best with samples at 48K bps speed or multiples of 48K. As Miditzer's fluidsynth is usually running at 44.1k speed, the sound card driver may have to do conversion realtime from 44.1K to 48K before output to speakers. So increase the background task may help. Or like PerS, get a better soundcard because a soundcard that does the 44.1K to 48K conversion in hardware requires less background CPU cycles .

User avatar
Jim Henry
Admin Group
Posts: 6134
Joined: Mon May 23, 2005 11:44 pm
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: United States

Re: Delayed Sound

Post by Jim Henry » Tue Apr 17, 2012 4:53 pm

You can set the sample rate used by FluidSynth in the Miditzer settings. Matching it to your hardware should improve performance as pointed out by reuel. This may be a setting that doesn't "take" until after you shut down and restart the Miditzer.
Jim Henry

User avatar
Per_S
Posts: 311
Joined: Wed Jan 26, 2005 10:15 am
How many Style 216 did Wurlitzer make?: 0
Location: Sweden

Re: Delayed Sound

Post by Per_S » Wed Apr 18, 2012 9:05 am

reuel wrote:As fluidsynth and your sound card drivers are BACKGROUND
Here’s my comment on this item. I’m not convinced that the Fluidsynth is running in the background. It’s loaded as a part of Miditzer and is running as a program, not as a background service. I took a look at the Miditzer.exe itself while running Ron’s MIDI concert, see picture.
Miditzer_exe.jpg
There it can be seen that the Fluidsynth is doing the majority of the number crunching within Miditzer.exe
I would vote for setting the priority to “Programs” rather than “Background services”. Realistically, I don’t think it makes much of a difference since Miditzer is probably the only program running (apart from the usual Windows overhead) while playing.
You do not have the required permissions to view the files attached to this post.
Per S

reuel
Senior Member
Posts: 219
Joined: Tue Nov 03, 2009 5:44 am
Spam Stopper: theatre organ
How many Style 216 did Wurlitzer make?: 12
Location: Australia

Re: Delayed Sound

Post by reuel » Fri Apr 20, 2012 7:12 pm

delayed sound.png
OK - lets agree that Fluidsynth is part of Miditzer.

Still there is the mistake many make puting Mitizer to "real time" and then complain about delayed sound.

Many new computers come with on-board sound chip or cheap software based Sound card (example Audigy SE).
These devices as well as Windows Mixers DO require CPU time. It is no use Miditzer-Fluisynth runs at "real-time" and then the sound device & Windows 7 process holds-up and delays the sound output.

All the talk about using ASIO or Port-Audio or Wave-RT etc for fluidsynth only means that we are just trying to bypass some of the Windows BACKGROUND sound processing.

Setting the priority to background balances the priority and will help performance.

High prioity for programs benefit better only if the programs do not need external I/O - example a Scientific calculation or CAD/video rendering.

Delayed sound also depends on the sound fonts used. Many wave samples of ALLMAN's sound fonts have a longer silence time before speaking (see attached PIC). So people who complains about delayed sound should also specify what sound fonts they are using. Perhaps some sound fonts can be improved.

I am using Emulator X3 as sound engine and I try to remove most of the silent part of the wave samples to further reduce delayed sound.
You do not have the required permissions to view the files attached to this post.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest